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Preface

Hopefully you’ll find something useful in this little book

– Adel

This document was created by LYX and is fully hyperlinkable that is to say you
can click on the any item on the table of contents or on the list of figures to
reach immediately to your target. Also, you can click on the figure number seen
within the text to reach to the figure. Thanks are due to LYX for its ability to
make documents fully hyperlinkable and hypreclickable.

Note: This is a part of my book “LYX For the Impatient” which is still under
preparation. Hope that I can finish it as soon as possible.
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1 References (Bibliography) in
LYX

1.1 Citation Versus Reference List

F Citation or “reference in text” is the expression written in the text de-
noting or referring the author, authors, published or unpublished source.

F Reference list also known as bibliographical list is the list found usually
at the end of your document in which you list all the authors or sources
mentioned in your document.

1.2 Citation Styles

Three major systems of citation styles (in-text references) are used by medical
publishers: citation-sequence, citation-name, and name-year. See Scientific
Style and Format.

1. In the citation-sequence system, (also known as numerical system)
numbers are used to refer to the reference list. References are numbered
in the list in the order they first appear in the text. For example, if
a reference by Zelinski is the first one referred to in the text, then the
Zelinski reference is number one in the list.

2. In the citation-name system, numbers are also used in the text to re-
fer to the reference list. However, the references in the list are numbered
in alphabetical order by author. Thus a reference authored by Adam
would be number 1, by Baker number 2, etc. These numbers are used in
the text regardless of the order in which they appear.

3. Finally, in the name-year system, (also known as author-year sys-
tem) in-text references consist of the surname of the author and the year
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Figure 1.1: Citation and reference list: Citation or “reference in text” is the
name of the author you put into your text, while, references also
known as “reference list” or “bibliographical list” is the list con-
taining all your sources of authors usually found at the end of your
document.

of publication, usually enclosed in parentheses, such as (Smith 2006).
The list of references is ordered first by author, then by year.

The first and the third systems are widely adopted in medical literature, while
the citation-name system is rarely used.

..3 Basic Citation Styles.

Author-Year System (Name Year)

. Citation-Name System.

citation-sequence system (Numerical)

1.3 BibTEX
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1.3.1 What is BibTEX

BibTEX Is bibliographic software for use with the scientific document prepa-
ration system LATEX and LYX. It is used to take data from a bibliographic
database (called a .bib file) and style information from a bibliography style file
(called a .bst file) to produce a formatted bibliography called a .bbl file, which
LATEX and LYX then reads.

By changing the style file (.bst) you can change the format of your references
by one click. Thus it makes changing references style a piece of cake.

Due to the many advantages of BibTEX it became widely accepted in almost
all published scientific journals.

1.3.2 Advantage of Using BibTEX Database

Easy formatting
No manual work needed for journal specific formatting of lists like the following:

F punctuate bibitems

F shorten page numbers

F change fonts/attributes for different fields

F remove dots from author’s given names/initials etc. if the journal style
stipulates it.

With a single press of button, BibTEX will handle all these. The punctuations,
font change, compression of page numbers etc. will be taken care of by the
appropriate .bst files which authors choose. Without BibTEX authors need to
waste a lot of time for doing this one-by-one manually.

Consistency in style
Keeping punctuations/fonts etc. consistent for each bibitem is a very difficult
task without BibTEX. Authors need to check each and every bibitems manually
for consistency.

Easy Cooperation with Publishers
Even, if you do not have the .bst style file, you can upload your .bib file to
publisher. The publisher, then can use your .bib file to format the references
in the way suitable for the his journal.
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Speed
As the typesetters do the conversion very quickly without waste of time us-
ing automated process, it will speed-up the publication process of your paper
considerably.

1.3.3 How to Make a BibTEX Database

F There are many programs that can save your reference database in BibTEX
format. Some of these programs are proprietary (EndNote, Reference
Manager) while others are free open source (JabRef, Kbib, Kbibtex,
Bibus, Referencer).

F The BibTEX database always ends by .bib file extension

F I recommend JabRef because:

1. It is free and open source

2. It is cross-platform, i.e. works on Windows, Mac and Linux. So
you can take your software with you whenever you changed your
operating system

3. You can insert citations directly from within JabRef into Open Of-
fice Writer

4. You can insert citations directly from within JabRef into LYX (but
I do not recommend this method)

5. Advanced BibTEX editor

6. Search functions within your database

7. Classification of entries

8. Various import and export formats

9. Customization of BibTEX fields.

10. Search Medline and Citeseer
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Installing JabRef
F Download JabRef. I recommend clicking on ”Download the latest stable

version”

F JabRef is written in Java code. you have to install Java to run JabRef.
If your PC doesn’t have Java, JabRef guides to download Java system.
It takes a few minutes.

F For Windows, choose the setup.exe file, download it, and run it. It should
install the program in C:\Program Files\JabRef and creating a shortcut
for you. If Java is installed in your operating system (jdk or jre), then
you can download the *.jar file and click it, it will run instantly

F For Mac, choose the one with OSX in the file name and dow whatever
Mac people do

F For Linux, just download the *.jar file. Click on *.jar file and that is all.
You can also use Synaptic to install JabRef

Using JabRef
F Open the software and create a new database. Otherwise, open existing

bib file. To create an new data base click on the “New bibtex database”
icon on the most upper left tool bar or by clicking on “File ▷ New
database”. Without a new database, you will not be able to do anything
with JabRef. Web search will add a BibTEX Key automatically for every
item you select. A BibTEX Key is a unified key that is used to identify
every item in your database (see later).

F If you have Web access, you can search Midline via pressing “F5” or by
clicking on “Search ▷ Web search”. A left pane will appear from which
you can select Midline or Google Scholar. See figure (1.2) for details.

F If you need to add a new reference, click BibTEX > new entry. Select
the entry type

F Add articles, books, and other documents you want

F For each document entered manually, create a BibTEX Key by clicking
the magic wand button. This creates the “Author2011” entry, and you
can modify this or customize it as you like. These keys are capitalization-
sensitive and should not contain spaces or punctuation. This is how you
will refer to the document in the paper you are writing. See figure (1.3)
for further explanation.
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Figure 1.2: JabRef Web Search Pane

Where to save the BibTEX database?
I recommend putting it in the same folder of your thesis or article

Formatting the References: BibTEX Style Files
When using BibTEX, you don’t control directly the format of references you
cite. The formatting is controlled by a BibTEX Style File (.bst). Each BST
formats things differently. Many journals offer their own BibTEX style files.
For most purposes you can use something like the vancouver format acceptable
by most medical and dental journals. In Linux (Ubuntu, Linux Mint and
Debian or Debian derived distros) you have to install “texlive-publishers” via
Synaptic or your favorite package manager. In Windows, you have to search for
“vancouver” in the Miktex package manager (Start ▷Miktex ▷ Maintenance
(Admin) ▷ Package Management (Admin)) and install it.

1.4 Inserting References in LYX

3 basic steps:

1. Select your bibliographical data base and decide the reference list style

2. Select your citation style

3. Insert a citation in your text
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Figure 1.3: Bibtex Key Generation

..3 Basic Steps to Create References in LyX.

Insert Citation

. Select Citation Style.

Select Reference List Style

Details is as follows:

1. To create a reference list. Go to the end of your document1 and click
Insert > List / TOC > BibTEX Bibliography. The insert BibTEX bibli-
ography command serves two purposes - it controlled where the bibliog-
raphy would appear in the text and also specified the file containing the
bibliography information.

a) Select Add > Browse and go to your .bib file which should be found
in the same folder of your document, click Open, then Add.

b) Select the style from the lower pane.

c) Finally click OK.

1Most probably, you need to put your reference list at the end of your document. Some-
times, you need to put it before the Arabic summary, appendix or errata. This is not a
big deal, you can put it anywhere in your document. Just put your cursor at you wish
and click insert.
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d) You can also tick “add bibliography to TOC”, if you need your
reference title to be shown in the table of contents.

e) Thus you have determined your reference data base and inserted it.
You will see this at the site of insertion.

2

1

3

4

6

5

2. Select your citation style by clicking on Document > Settings > Bib-
liography > Natbib and select Natbib style you want either Numerical
of Author-Year. Why Natbib in particular, this is because most proba-
bly the Default (numerical), will not suit your needs and Jurabib is still
experimental.
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3. To cite a reference, place your cursor at the site you wish your reference
citation will be and click on Insert > Citation or the toolbar button ..
In the left pane, select the author name you need to be cited, click Add,
then select the citation style you need from the Formatting drop down
menu and finely click OK or Apply.

1 2

3

4
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1.5 Modifying References in LYX

Sometimes you may need to modify your citation and reference list styles. This
is done when you want to change the style from numerical to author-year or
vice versa. Also you may need to change the reference list as putting the year
before or after the title. To do this in LYX follow the following two easy steps:

Two easy steps

..1.
Select Citation Style by selecting Document > Settings > Bibli-
ography > Natbib > Numerical or Author-Year

..2.
Select Reference List Style by Clicking on BibTeX Created Bibli-
ography and Selecting Style from the Drop Down Combo Box

1.6 Citation Positioning

The fundamental factors to consider are:

1. How to cite within the text

2. Where to cite in the text

3. How to format the reference list

How to cite within the text
This is not a function of the .bst file. However, the bst file does impact on
citing within the text as citing requires bibtex to generate the correct data
for use. In general terms, you should regard citation format within the text
to be independent of bibliography style. The only time you will encounter
problems is that if you use a bibliography style that uses numbered references
and attempt to reference by author-year.

Where to cite in the text
This is of considerable concern when switching an article from one journal style
to another. If your paper is rejected from one journal, you may be faced with
switching citation style, bibliography style and citation positioning.

For example:

Diabetes is very common. [1]
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Diabetes is very common [1].

Diabetes is very common (Smith, 1994).

Notice that we have to position punctuation correctly.

Of course, this is not a pure function of LYX. You have to put your citations
in the place specified by the publisher.

1.7 Style of the numbers in the bibliography

By default, LYX and LATEX formats the entry numbers in the following way:

[1] Garcia, F. (2007). LATEX and the different bibliography
styles. TUGboat, 28(2).
[2] Goossens, M., Mittelbach, F. and Samarin, A. (1995). The
LATEX Companion. Addison-Wesley.

This behavior can be customized in the preamble with commands such as:

\renewcommand{\bibnumfmt}[1]{#1.}

This will give:

1. Garcia, F. (2007). LATEX and the different bibliography
styles. TUGboat, 28(2).
2. Goossens, M., Mittelbach, F. and Samarin, A. (1995). The
LATEX Companion. Addison-Wesley.

1.8 Journal Styles

Here are some of the most commonly used oral and dental journals and the
styles used with them. Some of the style files are supplied by the publisher,
others are made by the author, while others still have to be made, most prob-
ably by you.
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1.8.1 Elsevier Journals

All journals of Elsevier are supplied with bibtex style files which can be down-
loaded from their Internet site.

1. International Journal of Oral & Maxillofacial Surgery

elsarticle-template-3a-num.tex - model3-num-names.bst

2. Italian Journal of Medicine

elsarticle-template-3a-num.tex - model3-num-names.bst

3. Italian Oral Surgery

elsarticle-template-3a-num.tex - model3-num-names.bst

4. Journal of Oral and Maxillofacial Surgery

elsarticle-template-3a-num.tex - model3-num-names.bst

5. Oral and Maxillofacial Surgery Clinics of North America

elsarticle-template-3a-num.tex - model3-num-names.bst

6. Oral Oncology

elsarticle-template-3a-num.tex - model3-num-names.bst

7. Oral Oncology Extra

elsarticle-template-3a-num.tex - model3-num-names.bst

8. Oral Oncology Supplement

elsarticle-template-3a-num.tex - model3-num-names.bst

9. Oral Surgery, Oral Medicine, Oral Pathology, Oral Radiology and En-
dodontology

elsarticle-template-3a-num.tex - model3-num-names.bst

10. Archives of Oral Biology

elsarticle-template-3a-num.tex - model3-num-names.bst

11. Atlas of the Oral & Maxillofacial Surgery Clinics of North A

elsarticle-template-3a-num.tex - model3-num-names.bst

12. British Journal of Oral & Maxillofacial Surgery

elsarticle-template-3a-num.tex - model3-num-names.bst
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13. Dental Abstracts

elsarticle-template-3a-num.tex - model3-num-names.bst

14. Dental Clinics of North America

elsarticle-template-3a-num.tex - model3-num-names.bst

15. Dental Materials

elsarticle-template-3a-num.tex - model3-num-names.bst

16. Japanese Dental Science Review

elsarticle-template-3a-num.tex - model3-num-names.bst

17. Journal of Dental Sciences

elsarticle-template-3a-num.tex - model3-num-names.bst

18. Journal of Dentistry

elsarticle-template-3a-num.tex - model3-num-names.bst

19. Journal of Evidence-Based Dental Practice, Brazil Edition

elsarticle-template-3a-num.tex - model3-num-names.bst

20. Journal of Evidence-Based Dental Practice, Portugal Edition

elsarticle-template-3a-num.tex - model3-num-names.bst

21. The Journal of Evidence-Based Dental Practice

elsarticle-template-3a-num.tex - model3-num-names.bst

22. The Journal of Prosthetic Dentistry

elsarticle-template-3a-num.tex - model3-num-names.bst

23. Journal of Prosthodontic Research

elsarticle-template-3a-num.tex - model3-num-names.bst

24. The Saudi Dental Journal

elsarticle-template-2-harv.tex - model2-names.bst
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1.8.2 PubMed and BioMed Central

All journals of PubMed and BioMed Central uses the bmc_article.bst which
can be downloaded from their Internet site.

1. Diagnostic Pathology

Use bmc_article.bst supplied by the publisher. The publisher provides a
tex template to be used. A LYX template is also available by the author.

2. Open Dentistry Journal

Use Vancouver style supplied by LYX and LATEX

3. BMC Oral Health

Use bmc_article.bst supplied by the publisher. The publisher provides a
tex template to be used. A LYX template is also available by the author.

4. BMC Cancer

Use bmc_article.bst supplied by the publisher. The publisher provides a
tex template to be used. A LYX template is also available by the author.

5. Head & Neck Oncology

Unknown, needs further research to see what is applicable

6. Cancer Cell International

Use bmc_article.bst supplied by the publisher. The publisher provides a
tex template to be used. A LYX template is also available by the author.

7. Head & Face Medicine

Unknown, needs further research to see what is applicable

Citing articles in PubMed and BioMed Central
Articles in PubMed and BioMed Central Journals should be cited in the same
way as articles in a traditional journal. Because articles are not printed, they
do not have page numbers; instead, they are given a unique article number.

Article citations follow this format:

Authors: Title. Head Face Med [year], [volume number]:[article number].

e.g.

Roberts LD, Hassall DG, Winegar DA, Haselden JN, Nicholls AW, Griffin JL:
Increased hepatic oxidative metabolism distinguishes the action of Peroxisome
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Proliferator-Activated Receptor delta from Peroxisome Proliferator-Activated
Receptor gamma in the Ob/Ob mouse. Head Face Med 2009, 1:115.

1.8.3 Wiley-Blackwell

Publish many journals related to dentistry. Unfortunately, each one has its
own bibliographical style. The publisher does not provide any bibtex style file.
For some of these journals, the author produced bibtex style files.

1. Australian Dental Journal

2. Australian Endodontic Journal

3. Clinical Implant Dentistry and Related Research

4. Clinical Oral Implants Research

5. Community Dentistry and Oral Epidemiology

6. Dental Traumatology

7. Endodontic Topics

8. European Journal of Dental Education

9. European Journal of Oral Sciences

10. Gerodontology

11. International Dental Journal

12. International Endodontic Journal

13. International Journal of Dental Hygiene

14. International Journal of Paediatric Dentistry

15. Journal of Clinical Periodontology

16. Journal of Esthetic and Restorative Dentistry

17. Journal of Forensic Sciences

18. Journal of Investigative and Clinical Dentistry

19. Journal of Oral Pathology & Medicine

20. Journal of Oral Rehabilitation

21. Journal of Periodontal Research

22. Journal of Prosthodontics
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23. Journal of Public Health Dentistry

24. Molecular Oral Microbiology

25. Oral Diseases

Use oral_diseases.bst supplied by the author

26. Oral Surgery

27. Orthodontics & Craniofacial Research

28. Periodontology 2000

29. Special Care in Dentistry

1.8.4 Springer Journals

To do
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